Shellshock – Lỗi bảo mật nguy hiểm hơn cả Heartbleed

Ước tính có thể gây ảnh hưởng nghiêm trọng đến hàng triệu người dùng máy tính Mac hay Linux.

Shellshock là tên gọi một mới phát hiện gần đây có khả năng gây ảnh hưởng trực tiếp đến ứng dụng Bash (Bourne again shell) vốn được dùng để điều khiển giao diện dòng lệnh trong nền tảng Linux cũng như HĐH Mac OS X.

tin-tuc-27-9-9

Shellshock cho phép kẻ xấu có thể tấn công, kiểm soát từ xa các hệ thống Linux hay Mac không được bảo vệ. Không như lỗi bảo mật vốn chỉ ảnh hưởng trực tiếp đến các hệ thống máy chủ – Shellshock nguy hiểm hơn rất nhiều vì có thể gây ảnh hưởng một lượng lớn máy tính cài đặt MAC OS X và nhiều thiết bị IoT khác vốn được nhúng các đoạn mã dựa trên nền Linux.

Theo dự đoán, lỗ hổng bảo mật mới phát hiện này có thể gây ảnh hưởng đến 500 triệu người dùng, cao hơn nhiều so với con số khoảng 500.000 người dùng bị ảnh hưởng bởi Heartbleed. Giới chuyên gia về an ninh và bảo mật đánh giá lỗ hổng bảo mật Shellshock thực sự rất tệ. Giáo sư an ninh mạng tại Đại học Birmingham City University khẳng định rằng nếu bạn đang sử dụng một máy tính MAC, rất nhiều khả năng bạn sẽ bị tấn công vì HĐH MAC OS X của Apple cũng dựa trên nền tảng Unix. Bên cạnh đó, người dùng Windows cũng không nên vội tự mãn vì chiếc của bạn có thể an toàn trước lỗ hổng bảo mật này – song, liệu có đảm bảo chắc một điều chiếc router/modem mà bạn đang dùng không sử dụng phần mềm được phát triển từ nền tảng Unix. Không chỉ vậy, Shellshock cũng có thể gây ảnh hưởng nghiêm trọng đến các web server sử dụng hệ thống Apache, vốn cũng là một nền tảng được phát triển từ Unix.

Lời khuyên trước mắt cho người dùng máy tính gia đình chính là hãy kiểm tra các bản cập nhật phần mềm mới nhất – đặc biệt là cho router băng thông rộng – và cài đặt những bản cập nhật mới này ngay khi có thể.

Theo: PCWorld VN

Bài viết liên quan